Si lors de l’installation de votre toute nouvelle instance de Concrete 5.7, lors du premier appel à l’installer intégré, rien ne s’affiche, voici deux points à vérifier :

  1. 1/ Votre version de PHP

Depuis les versions 5.7, Concrete5 requiert une version PHP 5.3.3 ou supérieure. Pour vérifier la version de PHP installée sur votre serveur:

  • lancez “php -v” depuis un terminal si vous y avez accès;
  • exécutez un fichier PHP contenant phpinfo();
  • demandez à votre hébergeur.

  1. 2/ L’URL appelée

L’installation de Concrete 5.7.4 plante si votre url contient un underscore, ce qui peut être le cas sur un sous-domaine de test.

Ex : test_concrete574.ndd.ext

Le message d’erreur (à consulter sur les logs du serveur) est assez sibyllin :

PHP Fatal error: Uncaught exception 'Exception' with message '"core/app" is not a valid asset group handle'

c’est assez simple à corriger. Supprimez le underscore ou remplacez le par “-” (touche 6 de votre clavier) au sein de votre VirtualHost.

PACCOU
Alexandre
Chef de projet web